Friday 22 June 2012

MPLS: Inter-AS VPNs: Option C: Multi-hop peering with remote PE

MPLS: Inter-AS VPNs: Option C: Multi-hop peering with remote PE

Let’s take a small topology to understand Inter-AS VPNs with “Option C – Direct peering with the remote PE”


·         PE1, P1 and ASBR1 are part of AS 100.
·         PE2, P2 and ASBR2 are part of AS 200.
·         PE1 – PE2: EBGP VPNV4 (that means one AS must share its internal PE loopback to other AS)
·         ASBR1 – ASBR2 : EBGP IPV4
·         Since PEs are directly peering, they learn about VPN routes directly, and VPN label is going to be constant throughout the path.
·         Only the transport label will be swapped by the pass-through routers.
·        

Label Distribution:

·         Transport label must be built between PE1 and PE2 through ASBRs.
·         CE1 advertises its loopback 11.11.11.11/32 to PE1 via VRF IGP
·         PE1 gets that and assigns a label, just say it is label X.
·         Since PE1 has EBGP VPNV4 neighbor PE2, it will advertise the prefix along with the label X.
·         In PE2, next-hop for 11.11.11.11/32 is PE1’s loopback 1.1.1.1
·         PE2 advertises this prefix to CE2.

Actual Data Path:

·         CE2 wants to send some traffic to CE1’s loopback 11.11.11.11/32
·         PE2 gets that traffic on VRF interface.
·         PE2 has the route 11.11.11.11 in its BGP table and the label is X.
·         Also the next-hop for 11.11.11.11/32 is 1.1.1.1 and it uses the Transport label as the top label.
·         So, pass-through routers P2, ASBR2, ASBR1 and P1 only swaps the top label (Transport label) and the VPN label remains unchanged.
·         PE1 gets the packet with transport label and the VPN label X.
·         It pops the top label and finds the VPN Label X.
·         PE1 performs another lookup on label X and finds that it belongs to VRF between PE1-CE1
·         Sends the unlabelled data to CE2.

Configuration:

·         CE1-PE1 link
·         CE2-PE2 link
·         VRF IGP between CE-PE
·         EBGP IPV4 between ASBRs
·         Advertise the PE’s loopback into BGP on ASBRs (ASBR1 has to advertise PE1’s loopback and ASBR2 has to advertise PE2’s loopback)
·         Redistribute BGP into IGP on ASBRs (This step is needed because I’m not running BGP between PE-ASBR)
·         EBGP VPNV4 between PE1 and PE2.

Building the LSP between PE1 and PE2.

PE1(config-router)#do show run | begin router ospf
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 100.1.12.1 0.0.0.0 area 0
!

P1(config-if)#do show run | begin router ospf
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 100.1.12.2 0.0.0.0 area 0
 network 100.1.23.2 0.0.0.0 area 0
!

P2(config-if)#do show run | begin router ospf
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 100.1.23.3 0.0.0.0 area 0
 network 100.1.34.3 0.0.0.0 area 0
!

PE2(config-router)#do show run | begin router ospf
router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
 network 4.4.4.4 0.0.0.0 area 0
 network 100.1.34.4 0.0.0.0 area 0
!

ASBR1(config)#ip prefix-list PE2-LOOP permit 4.4.4.4/32
ASBR1(config)#route-map PE2-LOOP
ASBR1(config-route-map)#match ip address prefix-list PE2-LOOP
ASBR1(config-route-map)#route-map PE2-LOOP deny 100
ASBR1(config-route-map)#router ospf 1
ASBR1(config-router)#redistribute bgp 100 subnets route-map PE2-LOOP
ASBR1(config-router)#

ASBR2(config)#ip prefix-list PE1-LOOP permit 1.1.1.1/32
ASBR2(config)#route-map PE1-LOOP
ASBR2(config-route-map)#match ip address prefix-list PE1-LOOP
ASBR2(config-route-map)#route-map PE1-LOOP deny 100
ASBR2(config-route-map)#router ospf 1
ASBR2(config-router)#redistribute bgp 200 subnets route-map PE1-LOOP
ASBR2(config-router)#

PE1#show ip route 4.4.4.4
Routing entry for 4.4.4.4/32
 Known via "ospf 1", distance 110, metric 1
 Tag 200, type extern 2, forward metric 128
  Last update from 100.1.12.2 on Serial1/1, 00:01:53 ago
  Routing Descriptor Blocks:
  * 100.1.12.2, from 7.7.7.7, 00:01:53 ago, via Serial1/1
      Route metric is 1, traffic share count is 1
      Route tag 200

PE1#ping 4.4.4.4 source 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 112/159/200 ms
PE1#

PE2#show ip route 1.1.1.1
Routing entry for 1.1.1.1/32
  Known via "ospf 1", distance 110, metric 1
  Tag 100, type extern 2, forward metric 128
  Last update from 100.1.34.3 on Serial1/1, 00:01:15 ago
  Routing Descriptor Blocks:
  * 100.1.34.3, from 8.8.8.8, 00:01:15 ago, via Serial1/1
      Route metric is 1, traffic share count is 1
      Route tag 100

PE2#ping 1.1.1.1 source 4.4.4.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 4.4.4.4
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 148/160/180 ms
PE2#

Observations:

·         I have advertised PE2 loopback 4.4.4.4 into BGP in ASBR2 and the same route has been redistributed into OSPF in ASBR1.
·         I have advertised PE1 loopback 1.1.1.1 into BGP in ASBR1 and the same route has been redistributed into OSPF in ASBR2.
·         Since internal routes are getting leaked to other AS, it is better to make sure that no other routes can propagate, hence deny statement at the end of the route-map
·         Although I have not configured here, AS’s prefer tagging the no-export community to the loopback, so that remote AS cannot send this route to other AS.
·         PE1 and PE2 can ping their respective loopbacks.

Now, let’s see the Transport label between PE1-PE2:

PE1#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     2.2.2.2/32        0          Se1/1      point2point
17     Pop tag     100.1.27.0/24     0          Se1/1      point2point
18     17          7.7.7.7/32        0          Se1/1      point2point
19     18          4.4.4.4/32        0          Se1/1      point2point
PE1#

P1#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     1.1.1.1/32        103891     Se1/1      point2point
17     Pop tag     7.7.7.7/32        139916     Se1/0      point2point
18     Untagged    4.4.4.4/32        1040       Se1/0      point2point
P1#

ASBR1#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     16          1.1.1.1/32        0          Se1/0      point2point
17     Pop tag     2.2.2.2/32        0          Se1/0      point2point
18     Pop tag     100.1.12.0/24     0          Se1/0      point2point
ASBR1#

PE2#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     100.1.38.0/24     0          Se1/1      point2point
17     Pop tag     3.3.3.3/32        0          Se1/1      point2point
18     17          8.8.8.8/32        0          Se1/1      point2point
19     18          1.1.1.1/32        0          Se1/1      point2point
PE2#

P2#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     4.4.4.4/32        113879     Se1/1      point2point
17     Pop tag     8.8.8.8/32        139738     Se1/0      point2point
18     Untagged    1.1.1.1/32        1040       Se1/0      point2point
P2#

ASBR2#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     100.1.34.0/24     0          Se1/0      point2point
17     Pop tag     3.3.3.3/32        0          Se1/0      point2point
18     16          4.4.4.4/32        0          Se1/0      point2point
ASBR2#

ASBR1#show ip bgp 4.4.4.4
BGP routing table entry for 4.4.4.4/32, version 3
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Not advertised to any peer
  200
    100.1.78.8 from 100.1.78.8 (8.8.8.8)
      Origin IGP, metric 129, localpref 100, valid, external, best
ASBR1#

ASBR2#show ip bgp 1.1.1.1
BGP routing table entry for 1.1.1.1/32, version 3
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Not advertised to any peer
  100
    100.1.78.7 from 100.1.78.7 (7.7.7.7)
      Origin IGP, metric 129, localpref 100, valid, external, best
ASBR2#

Observations:

For PE2’s loopback 4.4.4.4:
·         PE1 is using out-label 18 to reach 4.4.4.4
·         P1 MPLS table shows that, it is sending untagged packet to ASBR1 on Ser1/0, which means ASBR1 has not assigned any label for this PE2’s loopback 4.4.4.4
·         Yes, if we check the ASBR table, it doesn’t have any local tag for 4.4.4.4

For PE1’s loopback 1.1.1.1:
·         PE2 is using out-label 18 to reach 1.1.1.1
·         P2 MPLS table shows that, it is sending untagged packet to ASBR2 on Ser1/0, which means ASBR2 has not assigned any label for this PE1’s loopback 1.1.1.1
·         Yes, if we check the ASBR table, it doesn’t have any local tag for 1.1.1.1

·         This is expected behavior, as LDP assigns labels automatically for IGP learned routes and not for BGP learned routes.
·         P1 and P2 are learning PE’s loopbacks through IGP and hence they assigning the labels, but ASBRs didn’t assign any labels for the PE’s loopbacks.

·         Solution is to use IPV4 + Label between ASBRs


How BGP Sends MPLS Labels with Routes

When BGP (EBGP and IBGP) distributes a route, it can also distribute an MPLS label that is mapped to that route. The MPLS label mapping information for the route is carried in the BGP update message that contains the information about the route. If the next hop is not changed, the label is preserved.

When you issue the neighbor send-label command on both BPG routers, the routers advertise to each other that they can then send MPLS labels with the routes. If the routers successfully negotiate their ability to send MPLS labels, the routers add MPLS labels to all outgoing BGP updates.

ASBR1(config)#router bgp 100
ASBR1(config-router)#neighbor 100.1.78.8 send-label
ASBR1(config-router)#
*Jun 22 10:33:00.262: %BGP-5-ADJCHANGE: neighbor 100.1.78.8 Down Capability changed
*Jun 22 10:33:00.802: %BGP-5-ADJCHANGE: neighbor 100.1.78.8 Up
ASBR1(config-router)#

ASBR2(config)#router bgp 200
ASBR2(config-router)#neighbor 100.1.78.7 send-label
ASBR2(config-router)#
*Jun 22 10:32:49.598: %BGP-5-ADJCHANGE: neighbor 100.1.78.7 Down Capability changed
*Jun 22 10:32:50.386: %BGP-5-ADJCHANGE: neighbor 100.1.78.7 Up
ASBR2(config-router)#

ASBR1#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     16          1.1.1.1/32        0          Se1/0      point2point
17     Pop tag     2.2.2.2/32        0          Se1/0      point2point
18     Pop tag     100.1.12.0/24     0          Se1/0      point2point
19     Pop tag     100.1.78.8/32     0          Se1/1      point2point
20     18          4.4.4.4/32        0          Se1/1      point2point
ASBR1#

ASBR2#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     100.1.34.0/24     0          Se1/0      point2point
17     Pop tag     3.3.3.3/32        0          Se1/0      point2point
18     16          4.4.4.4/32        0          Se1/0      point2point
19     Pop tag     100.1.78.7/32     0          Se1/1      point2point
20     16          1.1.1.1/32        0          Se1/1      point2point
ASBR2#

ASBR1#show ip bgp 4.4.4.4
BGP routing table entry for 4.4.4.4/32, version 8
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Not advertised to any peer
  200
    100.1.78.8 from 100.1.78.8 (8.8.8.8)
      Origin IGP, metric 129, localpref 100, valid, external, best
      mpls labels in/out 20/18
ASBR1#

ASBR2#show ip bgp 1.1.1.1
BGP routing table entry for 1.1.1.1/32, version 8
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Not advertised to any peer
  100
    100.1.78.7 from 100.1.78.7 (7.7.7.7)
      Origin IGP, metric 129, localpref 100, valid, external, best
      mpls labels in/out 20/16
ASBR2#

P2#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     4.4.4.4/32        113879     Se1/1      point2point
17     Pop tag     8.8.8.8/32        139738     Se1/0      point2point
18     20          1.1.1.1/32        0          Se1/0      point2point
P2#

P1#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     1.1.1.1/32        103891     Se1/1      point2point
17     Pop tag     7.7.7.7/32        139916     Se1/0      point2point
18     20          4.4.4.4/32        0          Se1/0      point2point
P1#

Observations:

·         Now we see end to end label switched path for PE1 and PE2.

Configuring EBGP VPNV4 between PE1-PE2:

PE1(config)#router bgp 100
PE1(config-router)#no bgp default ipv4-unicast
PE1(config-router)#neighbor 4.4.4.4 remote-as 200
PE1(config-router)#neighbor 4.4.4.4 update-source loopback 0
PE1(config-router)#address-family vpnv4 unicast
PE1(config-router-af)#neighbor 4.4.4.4 activate
PE1(config-router-af)#exit
PE1(config-router)#neighbor 4.4.4.4 ebgp-multihop
PE1(config-router)#
*Jun 22 11:09:32.850: %BGP-5-ADJCHANGE: neighbor 4.4.4.4 Up
PE1(config-router)#

PE2(config)#router bgp 200
PE2(config-router)#no bgp default ipv4-unicast
PE2(config-router)#neighbor 1.1.1.1 remote-as 100
PE2(config-router)#neighbor 1.1.1.1 update-source loopback 0
PE2(config-router)#address-family vpnv4 unicast
PE2(config-router-af)#neighbor 1.1.1.1 activate
PE2(config-router-af)#exit
PE2(config-router)#neighbor 1.1.1.1 ebgp-multihop
PE2(config-router)#
*Jun 22 11:09:06.138: %BGP-5-ADJCHANGE: neighbor 1.1.1.1 Up
PE2(config-router)#

Mutual redistribution between VRF OSPF and MP-BGP in PEs:

PE1(config-router)#address-family ipv4 vrf VPN_A
PE1(config-router-af)#redistribute ospf 100 vrf VPN_A
PE1(config-router-af)#

PE1(config-router-af)#router ospf 100 vrf VPN_A
PE1(config-router)#redistribute bgp 100 subnets
PE1(config-router)#

PE2(config-router)#address-family ipv4 vrf VPN_A
PE2(config-router-af)#redistribute ospf 100 vrf VPN_A
PE2(config-router-af)#

PE2(config-router-af)#router ospf 100 vrf VPN_A
PE2(config-router)#redistribute bgp 200 subnets
PE2(config-router)#

PE1#show ip bgp vpnv4 all
BGP table version is 9, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrf VPN_A)
*> 10.1.15.0/24     0.0.0.0                  0         32768 ?
*> 10.1.46.0/24     4.4.4.4                  0             0 200 ?
*> 11.11.11.11/32   10.1.15.5               65         32768 ?
*> 12.12.12.12/32   4.4.4.4                 65             0 200 ?
PE1#

CE1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 2 subnets
C       10.1.15.0 is directly connected, Serial1/0
O IA    10.1.46.0 [110/65] via 10.1.15.1, 00:00:46, Serial1/0
     11.0.0.0/32 is subnetted, 1 subnets
C       11.11.11.11 is directly connected, Loopback0
     12.0.0.0/32 is subnetted, 1 subnets
O IA    12.12.12.12 [110/129] via 10.1.15.1, 00:00:46, Serial1/0
CE1#ping 12.12.12.12

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.12.12.12, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 176/212/244 ms
CE1#

PE2#show ip bgp vpnv4 all
BGP table version is 9, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrf VPN_A)
*> 10.1.15.0/24     1.1.1.1                  0             0 100 ?
*> 10.1.46.0/24     0.0.0.0                  0         32768 ?
*> 11.11.11.11/32   1.1.1.1                 65             0 100 ?
*> 12.12.12.12/32   10.1.46.6               65         32768 ?
PE2#

CE2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 2 subnets
O IA    10.1.15.0 [110/65] via 10.1.46.4, 00:01:29, Serial1/0
C       10.1.46.0 is directly connected, Serial1/0
     11.0.0.0/32 is subnetted, 1 subnets
O IA    11.11.11.11 [110/129] via 10.1.46.4, 00:01:29, Serial1/0
     12.0.0.0/32 is subnetted, 1 subnets
C       12.12.12.12 is directly connected, Loopback0
CE2#ping 11.11.11.11

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 160/195/244 ms
CE2#

Observations:

·         Connectivity is fine between CE1 and CE2
·         CE1 can reach CE2’s loopback 12.12.12.12/32
·         CE2 can reach CE1’s loopback 11.11.11.11/32

Now, let’s see the labels:

PE1#show ip bgp vpnv4 all labels
   Network          Next Hop      In label/Out label
Route Distinguisher: 100:1 (VPN_A)
   10.1.15.0/24     0.0.0.0         20/aggregate(VPN_A)
   10.1.46.0/24     4.4.4.4         nolabel/20
   11.11.11.11/32   10.1.15.5       21/nolabel
   12.12.12.12/32   4.4.4.4         nolabel/21

PE1#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     2.2.2.2/32        0          Se1/1      point2point
17     Pop tag     100.1.27.0/24     0          Se1/1      point2point
18     17          7.7.7.7/32        0          Se1/1      point2point
19     18          4.4.4.4/32        0          Se1/1      point2point
20     Aggregate   10.1.15.0/24[V]   520
21     Untagged    11.11.11.11/32[V] 520        Se1/0      point2point
PE1#show ip cef vrf VPN_A 12.12.12.12
12.12.12.12/32, version 22, epoch 0, cached adjacency to Serial1/1
0 packets, 0 bytes
  tag information set
    local tag: VPN-route-head
    fast tag rewrite with Se1/1, point2point, tags imposed: {18 21}
  via 4.4.4.4, 0 dependencies, recursive
    next hop 100.1.12.2, Serial1/1 via 4.4.4.4/32
    valid cached adjacency
    tag rewrite with Se1/1, point2point, tags imposed: {18 21}
PE1#


PE2#show ip bgp vpnv4 all labels
   Network          Next Hop      In label/Out label
Route Distinguisher: 100:1 (VPN_A)
   10.1.15.0/24     1.1.1.1         nolabel/20
   10.1.46.0/24     0.0.0.0         20/aggregate(VPN_A)
   11.11.11.11/32   1.1.1.1         nolabel/21
   12.12.12.12/32   10.1.46.6       21/nolabel

PE2#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     100.1.38.0/24     0          Se1/1      point2point
17     Pop tag     3.3.3.3/32        0          Se1/1      point2point
18     17          8.8.8.8/32        0          Se1/1      point2point
19     18          1.1.1.1/32        0          Se1/1      point2point
20     Aggregate   10.1.46.0/24[V]   520
21     Untagged    12.12.12.12/32[V] 520        Se1/0      point2point
PE2#
PE2#show ip cef vrf VPN_A 11.11.11.11
11.11.11.11/32, version 24, epoch 0, cached adjacency to Serial1/1
0 packets, 0 bytes
  tag information set
    local tag: VPN-route-head
    fast tag rewrite with Se1/1, point2point, tags imposed: {18 21}
  via 1.1.1.1, 0 dependencies, recursive
    next hop 100.1.34.3, Serial1/1 via 1.1.1.1/32
    valid cached adjacency
    tag rewrite with Se1/1, point2point, tags imposed: {18 21}
PE2#

CE2#trace 11.11.11.11

Type escape sequence to abort.
Tracing the route to 11.11.11.11

  1 10.1.46.4 72 msec 28 msec 48 msec
  2 100.1.34.3 [MPLS: Labels 18/21 Exp 0] 204 msec 176 msec 200 msec
  3 100.1.38.8 [MPLS: Labels 20/21 Exp 0] 172 msec 192 msec 216 msec
  4 100.1.78.7 [MPLS: Labels 16/21 Exp 0] 240 msec 188 msec 200 msec
  5 100.1.27.2 [MPLS: Labels 16/21 Exp 0] 248 msec 204 msec 172 msec
  6 10.1.15.1 [MPLS: Label 21 Exp 0] 232 msec 236 msec 188 msec
  7 10.1.15.5 232 msec *  220 msec
CE2#


CE1#traceroute 12.12.12.12

Type escape sequence to abort.
Tracing the route to 12.12.12.12

  1 10.1.15.1 80 msec 16 msec 20 msec
  2 100.1.12.2 [MPLS: Labels 18/21 Exp 0] 216 msec 172 msec 232 msec
  3 100.1.27.7 [MPLS: Labels 20/21 Exp 0] 188 msec 188 msec 200 msec
  4 100.1.78.8 [MPLS: Labels 18/21 Exp 0] 204 msec 220 msec 204 msec
  5 100.1.38.3 [MPLS: Labels 16/21 Exp 0] 156 msec 184 msec 188 msec
  6 10.1.46.4 [MPLS: Label 21 Exp 0] 236 msec 140 msec 140 msec
  7 10.1.46.6 232 msec *  204 msec
CE1#

Observations:

·         PE1 has assigned a VPN label 21 for CE1’S loopback 11.11.11.11 and the same label has been used by PE2 as out label.
·         PE2 has assigned a VPN label 21 for CE2’s loopback 12.12.12.12 and the same label has been used by PE1 as out label.
·         VPN label is unchanged throughout the path
·         Only the transport label is swapped by pass-through routers.




No comments:

Post a Comment