Tuesday 23 October 2012

How Redistribution works?


How Redistribution works?

   ·         Redistribution simply means transferring routes from one protocol to another protocol

·         Each protocol has different metric to find the best path, so we must be careful while redistributing routes from one protocol to another protocol.

 

·         But, if we see how redistribution works, there are 2 basic steps the router goes through for redistributing routes from one protocol to another protocol.

·         Example: Let’s assume Router A wants to redistribute routes from EIGRP to OSPF

·         Step 1: Router first finds the EIGRP routes; “show ip route eigrp” will show the routes which router is using EIGRP to reach them and redistributes them into OSPF.

·         Step 2: Router then finds the connected interfaces that are part of EIGRP and redistributing them into OSPF.

 

·         Let me take a small topology to configure this one:

 

EIGRP--------------------------EIGRP----OSPF-------------------------OSPF

R2----s1/0-----------------s1/0------R1-----s1/1--------------s1/1----R3

10.1.12.2-------------------10.1.12.2---10.1.13.1---------------10.1.13.3

 

 

Configs before redistribution:

 

R2(config-router)#do show run | sec router

router eigrp 100

 network 2.2.2.2 0.0.0.0

 network 10.1.12.2 0.0.0.0

 no auto-summary

 auto-summary

 eigrp router-id 2.2.2.2

R2(config-router)#

 

R1(config-router)#do show run | sec router

router eigrp 100

 network 10.1.12.1 0.0.0.0

 no auto-summary

 auto-summary

 eigrp router-id 1.1.1.1

router ospf 1

 router-id 1.1.1.1

 log-adjacency-changes

 network 10.1.13.1 0.0.0.0 area 0

R1(config-router)#

 

R3(config-router)#do show run | sec router

router ospf 1

 router-id 3.3.3.3

 log-adjacency-changes

 network 3.3.3.3 0.0.0.0 area 0

 network 10.1.13.3 0.0.0.0 area 0

R3(config-router)#

R3(config-router)#

 

·         Now, let’s see the routing tables:

 

R2(config-if)#do show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     2.0.0.0/32 is subnetted, 1 subnets

C       2.2.2.2 is directly connected, Loopback0

     10.0.0.0/24 is subnetted, 1 subnets

C       10.1.12.0 is directly connected, Serial1/0

R2(config-if)#

 

Observation:

·         10.1.12.0 is part of EIGRP

·         2.2.2.2 is part of EIGRP

·         But, these interfaces are connected, that’s why they are not showing up as EIGRP routes.

·         R2 is not learning about R3’s loopback 3.3.3.3, because of no redistribution in R1 from OSPF to EIGRP

 

R3#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     3.0.0.0/32 is subnetted, 1 subnets

C       3.3.3.3 is directly connected, Loopback0

     10.0.0.0/24 is subnetted, 1 subnets

C       10.1.13.0 is directly connected, Serial1/1

R3#

 

 

Observation:

·         10.1.13.0 is part of OSPF

·         3.3.3.3 is part of OSPF

·         But, these interfaces are connected, that’s why they are not showing up as OSPF routes.

·         R3 is not learning about R2’s loopback 2.2.2.2, because of no redistribution in R1 from IEGRP to OSPF

 

 

R1(config-if)#do show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     2.0.0.0/32 is subnetted, 1 subnets

D       2.2.2.2 [90/2297856] via 10.1.12.2, 00:03:02, Serial1/0

     3.0.0.0/32 is subnetted, 1 subnets

O       3.3.3.3 [110/65] via 10.1.13.3, 00:34:05, Serial1/1

     10.0.0.0/24 is subnetted, 2 subnets

C       10.1.13.0 is directly connected, Serial1/1

C       10.1.12.0 is directly connected, Serial1/0

R1(config-if)#

 

Observation:

·         10.1.12.0 is part of EIGRP, but it’s connected interface

·         2.2.2.2 is learning via EIGRP,

·         10.1.13.0 is part of OSPF, but it’s connected interface

·         3.3.3.3 is learning via OSPF

 

·         Let me configure redistribution between OSPF and EIGRP in R1 so that R2 and R3 learn other router’s loopbacks.

 

R1(config-if)#router ospf 1

R1(config-router)#redistribute eigrp 100 subnets

R1(config-router)#exit

R1(config)#router eigrp 100

R1(config-router)#redistribute ospf 1 metric  1 1 1 1 1

R1(config-router)#

 

R2#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     2.0.0.0/32 is subnetted, 1 subnets

C       2.2.2.2 is directly connected, Loopback0

     3.0.0.0/32 is subnetted, 1 subnets

D EX    3.3.3.3 [170/2560512256] via 10.1.12.1, 00:02:07, Serial1/0

     10.0.0.0/24 is subnetted, 2 subnets

D EX    10.1.13.0 [170/2560512256] via 10.1.12.1, 00:02:07, Serial1/0

C       10.1.12.0 is directly connected, Serial1/0

R2#

 

R3#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     2.0.0.0/32 is subnetted, 1 subnets

O E2    2.2.2.2 [110/20] via 10.1.13.1, 00:02:41, Serial1/1

     3.0.0.0/32 is subnetted, 1 subnets

C       3.3.3.3 is directly connected, Loopback0

     10.0.0.0/24 is subnetted, 2 subnets

C       10.1.13.0 is directly connected, Serial1/1

O E2    10.1.12.0 [110/20] via 10.1.13.1, 00:02:41, Serial1/1

R3#

 

R1#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     2.0.0.0/32 is subnetted, 1 subnets

D       2.2.2.2 [90/2297856] via 10.1.12.2, 00:16:48, Serial1/0

     3.0.0.0/32 is subnetted, 1 subnets

O       3.3.3.3 [110/65] via 10.1.13.3, 00:02:57, Serial1/1

     10.0.0.0/24 is subnetted, 2 subnets

C       10.1.13.0 is directly connected, Serial1/1

C       10.1.12.0 is directly connected, Serial1/0

R1#

 

Observation:

 

·         R2 is learning R3’s loopback 3.3.3.3 and

·         R2 is also learning R1-R3 link 10.1.13.0, this is happening because of Step-2 in the redistribution process.

·         R3 is learning R2’s loopback 2.2.2.2 and

·         R3 is also learning R1-R2 link 10.1.12.0, this is happening because of Step-2 in the redistribution process.

 

·         During redistribution, step-2 happens by default

·         If we do something else which overwrites default behavior, then we are in trouble.

 

·         For step-2, router creates default route-map and if we create our own route-map to redistribute and if we forget add permit statement at the end, then we are in trouble.

 

·         Let me create a loopback interface in R1 and create a route-map to redistribute this loopback into OSPF

 

R1(config)#int loop0

R1(config-if)#ip address 1.1.1.1 255.255.255.255

R1(config-if)#route-map CONN

R1(config-route-map)#match interface loopback 0

R1(config-route-map)#router ospf 1

R1(config-router)#redistribute connected subnets route-map CONN

R1(config-router)#

 

·         Now, let me check the R3’s routing table:

 

R3#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     1.0.0.0/32 is subnetted, 1 subnets

O E2    1.1.1.1 [110/20] via 10.1.13.1, 00:00:27, Serial1/1

     2.0.0.0/32 is subnetted, 1 subnets

O E2    2.2.2.2 [110/20] via 10.1.13.1, 00:15:08, Serial1/1

     3.0.0.0/32 is subnetted, 1 subnets

C       3.3.3.3 is directly connected, Loopback0

     10.0.0.0/24 is subnetted, 1 subnets

C       10.1.13.0 is directly connected, Serial1/1

R3#

 

Observation:

·         R3 has R1’s loopback 1.1.1.1

·         But what happened to R1-R2 link 10.1.12.0 we had earlier?

·         But the route-map I created doesn’t have permit statement at the end.

·         Now, let me add permit statement at the end for the route-map

 

R1(config-router)#route-map CONN permit 20

 

·         Now, let me check R3’s routing table:

 

R3#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     1.0.0.0/32 is subnetted, 1 subnets

O E2    1.1.1.1 [110/20] via 10.1.13.1, 00:04:32, Serial1/1

     2.0.0.0/32 is subnetted, 1 subnets

O E2    2.2.2.2 [110/20] via 10.1.13.1, 00:19:13, Serial1/1

     3.0.0.0/32 is subnetted, 1 subnets

C       3.3.3.3 is directly connected, Loopback0

     10.0.0.0/24 is subnetted, 2 subnets

C       10.1.13.0 is directly connected, Serial1/1

O E2    10.1.12.0 [110/20] via 10.1.13.1, 00:00:27, Serial1/1

R3#

 

Observation:

·         R3 has R1-R2 link 10.1.12.0

·         This is because I have added permit statement at the end of the route-map now.

·         We have to take of the redistribution process, especially if we redistribute any connected interfaces using route-map

 

·         However if we are redistributing from IS-IS, IS-IS will not do the 2nd step and hence we need to manually redistribute the connected interface link by using “redistribute connected” command.

·         In IPV6, all the protocols follow only step-1 and they don’t follow the step-2 and hence we need to explicitly mention “include-connected” key-word at the end of the redistribution.

                 

Case-1: Let me configure IS-IS between R1-R2 instead of EIGRP and see:

 

IS-IS--------------------------IS-IS----OSPF-------------------------OSPF

R2----s1/0-----------------s1/0------R1-----s1/1--------------s1/1----R3

10.1.12.2-------------------10.1.12.2---10.1.13.1---------------10.1.13.3

 

 

Configs:

 

R1(config)#router isis 1

R1(config-router)#net 49.0001.1111.1111.1111.00

R1(config-router)#int ser1/0

R1(config-if)#ip router isis 1

R1(config-if)#router isis 1

R1(config-router)#is-type level-2-only

R1(config-router)#

 

R2(config)#router isis 1

R2(config-router)#net 49.0001.2222.2222.2222.00

R2(config-router)#int ser1/0

R2(config-if)#ip router isis 1

R2(config-if)#int loop0

R2(config-if)#ip router isis 1

R2(config-if)#router isis 1

R2(config-router)#is-type level-2-only

R2(config-router)#

 

R1(config-router)#do show run | sec router

 ip router isis 1

router ospf 1

 router-id 1.1.1.1

 log-adjacency-changes

 redistribute connected

 network 10.1.13.1 0.0.0.0 area 0

router isis 1

 net 49.0001.1111.1111.1111.00

 is-type level-2-only

R1(config-router)#

 

R3#show run | sec router

router ospf 1

 router-id 3.3.3.3

 log-adjacency-changes

 network 3.3.3.3 0.0.0.0 area 0

 network 10.1.13.3 0.0.0.0 area 0

R3#

 

R2(config-router)#do show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     2.0.0.0/32 is subnetted, 1 subnets

C       2.2.2.2 is directly connected, Loopback0

     10.0.0.0/24 is subnetted, 1 subnets

C       10.1.12.0 is directly connected, Serial1/0

R2(config-router)#

 

R1(config-router)#do show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     1.0.0.0/32 is subnetted, 1 subnets

C       1.1.1.1 is directly connected, Loopback0

     2.0.0.0/32 is subnetted, 1 subnets

i L2    2.2.2.2 [115/20] via 10.1.12.2, Serial1/0

     3.0.0.0/32 is subnetted, 1 subnets

O       3.3.3.3 [110/65] via 10.1.13.3, 00:14:12, Serial1/1

     10.0.0.0/24 is subnetted, 2 subnets

C       10.1.13.0 is directly connected, Serial1/1

C       10.1.12.0 is directly connected, Serial1/0

R1(config-router)#

 

R3#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     3.0.0.0/32 is subnetted, 1 subnets

C       3.3.3.3 is directly connected, Loopback0

     10.0.0.0/24 is subnetted, 1 subnets

C       10.1.13.0 is directly connected, Serial1/1

R3#

 

Observation:

 

·         R1 is learning about R2’s loopback 2.2.2.2 from IS-IS

·         R1 is learning about R3’s loopback 3.3.3.3 from OSPF

 

·         Now, let me redistribute between IS-IS and OSPF in R2

        

R1(config-router)#router isis 1

R1(config-router)#redistribute ospf 1 metric 10

R1(config-router)#router ospf 1

R1(config-router)#redistribute isis 1 subnets

R1(config-router)#

 

·         Now, let me see the Routing tables:

 

R2(config-router)#do show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     2.0.0.0/32 is subnetted, 1 subnets

C       2.2.2.2 is directly connected, Loopback0

     3.0.0.0/32 is subnetted, 1 subnets

i L2    3.3.3.3 [115/20] via 10.1.12.1, Serial1/0

     10.0.0.0/24 is subnetted, 2 subnets

i L2    10.1.13.0 [115/20] via 10.1.12.1, Serial1/0

C       10.1.12.0 is directly connected, Serial1/0

R2(config-router)#

 

R1(config-router)#do show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     1.0.0.0/32 is subnetted, 1 subnets

C       1.1.1.1 is directly connected, Loopback0

     2.0.0.0/32 is subnetted, 1 subnets

i L2    2.2.2.2 [115/20] via 10.1.12.2, Serial1/0

     3.0.0.0/32 is subnetted, 1 subnets

O       3.3.3.3 [110/65] via 10.1.13.3, 00:06:13, Serial1/1

     10.0.0.0/24 is subnetted, 2 subnets

C       10.1.13.0 is directly connected, Serial1/1

C       10.1.12.0 is directly connected, Serial1/0

R1(config-router)#

 

R3#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     2.0.0.0/32 is subnetted, 1 subnets

O E2    2.2.2.2 [110/20] via 10.1.13.1, 00:01:47, Serial1/1

     3.0.0.0/32 is subnetted, 1 subnets

C       3.3.3.3 is directly connected, Loopback0

     10.0.0.0/24 is subnetted, 1 subnets

C       10.1.13.0 is directly connected, Serial1/1

R3#

 

Observations:

·         R2 has R3’s loopback 3.3.3.3 as well as R1-R3 link 10.1.13.0

·         That is because when OSPF is redistributes into IS-IS, OSPF went through 2 steps mentioned in the beginning and thus R2 has even the R1-R3 link.

 

·         But, R3 has only R2’s loopback 2.2.2.2

·         R3 doesn’t have R1-R2 link

·         This is because, when IS-IS is redistributed into OSPF, only IS-IS routes got redistributed by default, it didn’t redistribute the connected interfaces that are part of IS-IS

·         Solution is to redistribute the connected interface explicitly under the OSPF process, using the “redistribute connected” command

 

R1(config)#router ospf 1

R1(config-router)#redistribute connected subnets

R1(config-router)#

 

R3#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     2.0.0.0/32 is subnetted, 1 subnets

O E2    2.2.2.2 [110/20] via 10.1.13.1, 00:14:01, Serial1/1

     3.0.0.0/32 is subnetted, 1 subnets

C       3.3.3.3 is directly connected, Loopback0

     10.0.0.0/24 is subnetted, 2 subnets

C       10.1.13.0 is directly connected, Serial1/1

O E2    10.1.12.0 [110/20] via 10.1.13.1, 00:02:39, Serial1/1

R3#

 

Case-2: Let me configure IPv6 IEGRP and IPV6 OSPF now and see:

 

RIP------------------------------RIP----OSPF-------------------------OSPF

R2----s1/0-----------------s1/0------R1-----s1/1--------------s1/1----R3

2001:12::1----------------- 2001:12::1--- 2001:13::1------------ 2001:13::3

 

Configs before redistribution:

 

R2#show run | sec router

ipv6 router rip RIPng

R2#

R2#show run int ser1/0

Building configuration...

 

Current configuration : 151 bytes

!

interface Serial1/0

 ip address 10.1.12.2 255.255.255.0

 ipv6 address 2001:12::2/64

 ipv6 enable

 ipv6 rip RIPng enable

 serial restart-delay 0

end

 

R2#show run int loop0

Building configuration...

 

Current configuration : 126 bytes

!

interface Loopback0

 ip address 2.2.2.2 255.255.255.255

 ipv6 address 2001:2::2/64

 ipv6 enable

 ipv6 rip RIPng enable

end

 

R2#

 

R3#show run | sec router

ipv6 router ospf 1

 log-adjacency-changes

R3#

R3#show run int ser1/1

Building configuration...

 

Current configuration : 164 bytes

!

interface Serial1/1

 ip address 10.1.13.3 255.255.255.0

 ip flow egress

 ipv6 address 2001:13::3/64

 ipv6 enable

 ipv6 ospf 1 area 0

 serial restart-delay 0

end

 

R3#show run int loop0

Building configuration...

 

Current configuration : 123 bytes

!

interface Loopback0

 ip address 3.3.3.3 255.255.255.255

 ipv6 address 2001:3::3/64

 ipv6 enable

 ipv6 ospf 1 area 0

end

 

R3#

 

R1#show run int ser1/0

Building configuration...

 

Current configuration : 168 bytes

!

interface Serial1/0

 ip address 10.1.12.1 255.255.255.0

 ip flow ingress

 ipv6 address 2001:12::1/64

 ipv6 enable

 ipv6 rip RIPng enable

 serial restart-delay 0

end

 

R1#

R1#show run int ser1/1

Building configuration...

 

Current configuration : 165 bytes

!

interface Serial1/1

 ip address 10.1.13.1 255.255.255.0

 ip flow ingress

 ipv6 address 2001:13::1/64

 ipv6 enable

 ipv6 ospf 1 area 0

 serial restart-delay 0

end

 

R1#

 

·         Now, let’s see the routing tables:

 

R2#show ipv6 route

IPv6 Routing Table - 6 entries

Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP

       U - Per-user Static route

       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary

       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

C   2001:2::/64 [0/0]

     via ::, Loopback0

L   2001:2::2/128 [0/0]

     via ::, Loopback0

C   2001:12::/64 [0/0]

     via ::, Serial1/0

L   2001:12::2/128 [0/0]

     via ::, Serial1/0

L   FE80::/10 [0/0]

     via ::, Null0

L   FF00::/8 [0/0]

     via ::, Null0

R2#

 

R3#show ipv6 route

IPv6 Routing Table - 6 entries

Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP

       U - Per-user Static route

       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary

       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

C   2001:3::/64 [0/0]

     via ::, Loopback0

L   2001:3::3/128 [0/0]

     via ::, Loopback0

C   2001:13::/64 [0/0]

     via ::, Serial1/1

L   2001:13::3/128 [0/0]

     via ::, Serial1/1

L   FE80::/10 [0/0]

     via ::, Null0

L   FF00::/8 [0/0]

     via ::, Null0

R3#

 

R1#show ipv6 route

IPv6 Routing Table - 8 entries

Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP

       U - Per-user Static route

       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary

       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

R   2001:2::/64 [120/2]

     via FE80::C001:6FF:FE48:0, Serial1/0

O   2001:3::3/128 [110/64]

     via FE80::C002:6FF:FE48:0, Serial1/1

C   2001:12::/64 [0/0]

     via ::, Serial1/0

L   2001:12::1/128 [0/0]

     via ::, Serial1/0

C   2001:13::/64 [0/0]

     via ::, Serial1/1

L   2001:13::1/128 [0/0]

     via ::, Serial1/1

L   FE80::/10 [0/0]

     via ::, Null0

L   FF00::/8 [0/0]

     via ::, Null0

R1#

 

Observation:

·         RIP is configured between R1-R2

·         R2 has advertised its loopback0 2001:2::2 into RIP and R1 has that RIP route installed in its routing table

·         OSPF is configured between R1-R3

·         R3 has advertised its loopback0 2001:3::3 into OSPF and R1 has that OSPF route in its routing table

 

Now, let me configure redistribution between RIPng and OSPFv3 in R1:

 

R1(config)#ipv6 router rip RIPng

R1(config-rtr)#redistribute ospf 1 metric 2

R1(config-rtr)#exit

R1(config)#ipv6 router ospf 1

R1(config-rtr)#redistribute rip RIPng

R1(config-rtr)#

 

Now, let’s see the Routing tables:

 

R2#show ipv6 route

IPv6 Routing Table - 7 entries

Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP

       U - Per-user Static route

       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary

       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

C   2001:2::/64 [0/0]

     via ::, Loopback0

L   2001:2::2/128 [0/0]

     via ::, Loopback0

R   2001:3::3/128 [120/3]

     via FE80::C000:6FF:FE48:0, Serial1/0

C   2001:12::/64 [0/0]

     via ::, Serial1/0

L   2001:12::2/128 [0/0]

     via ::, Serial1/0

L   FE80::/10 [0/0]

     via ::, Null0

L   FF00::/8 [0/0]

     via ::, Null0

R2#

 

R1(config-rtr)#do show ipv6 route

IPv6 Routing Table - 8 entries

Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP

       U - Per-user Static route

       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary

       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

R   2001:2::/64 [120/2]

     via FE80::C001:6FF:FE48:0, Serial1/0

O   2001:3::3/128 [110/64]

     via FE80::C002:6FF:FE48:0, Serial1/1

C   2001:12::/64 [0/0]

     via ::, Serial1/0

L   2001:12::1/128 [0/0]

     via ::, Serial1/0

C   2001:13::/64 [0/0]

     via ::, Serial1/1

L   2001:13::1/128 [0/0]

     via ::, Serial1/1

L   FE80::/10 [0/0]

     via ::, Null0

L   FF00::/8 [0/0]

     via ::, Null0

R1(config-rtr)#

 

R3#show ipv6 route

IPv6 Routing Table - 7 entries

Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP

       U - Per-user Static route

       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary

       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

OE2  2001:2::/64 [110/20]

     via FE80::C000:6FF:FE48:0, Serial1/1

C   2001:3::/64 [0/0]

     via ::, Loopback0

L   2001:3::3/128 [0/0]

     via ::, Loopback0

C   2001:13::/64 [0/0]

     via ::, Serial1/1

L   2001:13::3/128 [0/0]

     via ::, Serial1/1

L   FE80::/10 [0/0]

     via ::, Null0

L   FF00::/8 [0/0]

     via ::, Null0

R3#

 

Observation:

·         R2 has R3’s loopback 2001:3::3

·         R2 doesn’t have R1-R3 link, because in IPV6 redistribution step-2 will not happen by default

·         R3 has R2’s loopback 2001:2::2

·         R3 doesn’t have R1-R2 link, because in IPV6 redistribution step-2 will not happen by default

 

·         Solution is to add include-connected key-word while doing redistribution

 

R1(config-rtr)#ipv6 router rip RIPng

R1(config-rtr)#redistribute ospf 1 metric 2 include-connected

R1(config-rtr)#exit

R1(config)#ipv6 router ospf 1

R1(config-rtr)#redistribute rip RIPng include-connected

R1(config-rtr)#

 

·         Now, Let’s see the Routing tables:

 

R2#show ipv6 route

IPv6 Routing Table - 8 entries

Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP

       U - Per-user Static route

       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary

       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

C   2001:2::/64 [0/0]

     via ::, Loopback0

L   2001:2::2/128 [0/0]

     via ::, Loopback0

R   2001:3::3/128 [120/3]

     via FE80::C000:6FF:FE48:0, Serial1/0

C   2001:12::/64 [0/0]

     via ::, Serial1/0

L   2001:12::2/128 [0/0]

     via ::, Serial1/0

R   2001:13::/64 [120/3]

     via FE80::C000:6FF:FE48:0, Serial1/0

L   FE80::/10 [0/0]

     via ::, Null0

L   FF00::/8 [0/0]

     via ::, Null0

R2#

 

R1(config-rtr)#do show ipv6 route

IPv6 Routing Table - 8 entries

Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP

       U - Per-user Static route

       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary

       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

R   2001:2::/64 [120/2]

     via FE80::C001:6FF:FE48:0, Serial1/0

O   2001:3::3/128 [110/64]

     via FE80::C002:6FF:FE48:0, Serial1/1

C   2001:12::/64 [0/0]

     via ::, Serial1/0

L   2001:12::1/128 [0/0]

     via ::, Serial1/0

C   2001:13::/64 [0/0]

     via ::, Serial1/1

L   2001:13::1/128 [0/0]

     via ::, Serial1/1

L   FE80::/10 [0/0]

     via ::, Null0

L   FF00::/8 [0/0]

     via ::, Null0

R1(config-rtr)#

 

R3#show ipv6 route

IPv6 Routing Table - 8 entries

Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP

       U - Per-user Static route

       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary

       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

OE2  2001:2::/64 [110/20]

     via FE80::C000:6FF:FE48:0, Serial1/1

C   2001:3::/64 [0/0]

     via ::, Loopback0

L   2001:3::3/128 [0/0]

     via ::, Loopback0

OE2  2001:12::/64 [110/20]

     via FE80::C000:6FF:FE48:0, Serial1/1

C   2001:13::/64 [0/0]

     via ::, Serial1/1

L   2001:13::3/128 [0/0]

     via ::, Serial1/1

L   FE80::/10 [0/0]

     via ::, Null0

L   FF00::/8 [0/0]

     via ::, Null0

R3#

 

Observation:

·         R2 has R3’s loopback 2001:3::3

·         R2 also has R1-R3 link, 2001:13::/64

·         R3 has R2’s loopback 2001:2::2

·         R3 also has R1-R2 link, 2001:12::/64

 

No comments:

Post a Comment